WienerOPCS: WienerOPCS

  • Main Page
  • Related Pages

WienerOPCS

4.0.1912.0

OPC (OLE for Process Control) allows fast and secure access to data and information under Windows operating systems. As an industry-spanning, multi-vendor software interface, OPC minimizes connection and maintenance overheads.

This server, running on a computer with the Microsoft Windows XP, Windows 7 32 and 64 bit and Windows Server 2008 operating systems, enables access to W-IE-NE-R remote controllable hardware, so-called crates in the following sections of this manual, connected to the server computer via a CAN-bus network or a TCP/IP (SNMP) connection.

It is possible to

  • Access from any OPC Client application to the data of one or more servers.
  • Encapsulating the properties specific to the server and type of communication.
  • Restricting access rights by the underlying Microsoft DCOM.

This manual is divided in the following sections:

  • General Remarks
  • Installation and Version History
  • OPC Namespace Reference
  • Namespace Tree
  • Special Requirements for the WienerOPCS Server
  • Configuration File Reference
  • WienerOPCS Command Line Parameters
  • Modifying the WienerOPCS Service behavior
  • OPC Namespace Index
  • Configuration File Element Index
  • Software License
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:33 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: General Remarks

WienerOPCS

General Remarks

The only purpose of this manual is a description of the product. It must not be interpreted as a declaration of conformity for this product including the product and software.

W-IE-NE-R revises this product and manual without notice. Differences of the description in manual and product are possible.

W-IE-NE-R excludes completely any liability for loss of profits, loss of business, loss of use or data, interrupt of business, or for indirect, special incidental, or consequential damages of any kind, even if W-IE-NE-R has been advises of the possibility of such damages arising from any defect or error in this manual or product.

Any use of the product which may influence health of human beings requires the express written permission of W-IE-NE-R.

Products mentioned in this manual are mentioned for identification purposes only. Product names appearing in this manual may or may not be registered trademarks or copyrights of their respective companies.

No part of this product, including the product and the software may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any language in any form by any means with the express written permission of W-IW-NE-R.

W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:38 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Installation and Version History

WienerOPCS

Installation and Version History

WienerOPCS ReadMe 4.0.1912.0

1 Installation

The correct functionality of the OPC server software is dependent of software additional packages, which should be installed before.

1.1 Net-SNMP (necessary if you connect crates via TCP/IP)

Install net-snmp. You may download it from www.sourceforge.net, but a tested version of the windows installation file is available at our download area (www.wiener-d.com->Support->Downloads).

Only the "Base Components" are required. If you want to use the utilities to generate configuration scripts automatically, you have to install the and the "Perl SNMP Modules", too.

The default directory is c:\usr. If you change this directory, you have to move the WIENER-CRATE-MIB.txt file, which will be installed by the WienerOPCS installer in the c:\usr\share\snmp\mibs directory, to the appropriate directory.

Simple check: the command line utility

snmpget -v 2c -c public 192.168.91.80 sysUpTime.0

should return the time of the crate at IP 192.168.91.80.

If no crate is available at this time: The above command is working with Microsoft Windows, too.

(The SNMP functionality must be installed, it is not installed by default)

1.2 Kvaser CAN-Bus driver (only necessary if you connect crates via KVASER CAN-Bus hardware)

If you intend to use CAN-Bus hardware of the Kvaser company (www.kvaser.com), you must install the appropriate driver of your hardware. Please look at the hardware documentation of your Kvaser product for additional information.

We tested the server with a the Kvaser PCIcan 4xHS and driver version 7.6.8001.0. The driver is integrated in the kvaser_drivers_w2k_xp.exe software version 4.6a

1.3 Perl (Optional)

We supply some basic perl scripts to identify the connected crates and generate a configuration file automatically (subfolder util). If you want to use them you have to install ActivePerl (http://www.activestate.com/Products/Download/Download.plex?id=ActivePerl). We used ActivePerl 5.8.7.815 for testing.

After installation of Perl you have to install the NetSNMP perl modules. This is described in the NetSNMP Readme.txt file in the section "INSTALLATION - PERL MODULE".

1.4 OPC Core Components

The core components are free available from the OPC Foundation (www.opcfoundation.org). The server is tested with version 105.1.

This components are included in the WienerOPCS installer file.

1.5 WienerOPCS

The installation is done by the WienerOPCS installaction script.

2 Documentation

The complete documentation is installed in the "doc"-subfolder of the installation directory. The documentation is available as HTML and as Microsoft Help File (CHM).

3 Known Problems & Planed Enhancements

· SNMP: WIENER devices can handle just one TCP/UDP request at a time. So the SNMP communication of the OPC server may be interrupted if another client (e.g. web browser) does access the device at the same time. The OPC server will reconnect to the device automatically.

· Possible OPC DA 2.0.5 comliance test failure (some type conversion)

4 Version History

WIENER OPCS 4.0.1912.0, 2012/07/12 11:39:28

· Executable under windows XP, Windows 7 32bit, Windows 7 64bit and Windows Server 2008.

WIENER OPCS 3.0.1144.0, 2010/07/02 17:53:02

· New OPC items NetworkAddress, NetworkAddressStatic, RegulationMode, SupervisionMaxTemperature

WIENER OPCS 3.0.1111.0, 2010-06-07

· MPOD support

WIENER OPCS 3.0.1000.0, 2010-03-30

· Enable non-numeric IP addresses in the configuration file again.

WIENER OPCS 3.0.690.0, 2009-03-30

· Bugfix: Consecutive write operations, which modify only some bits of the data transfered to the device, failed if the intermediate tiome was too low. This regards the bit manipulation of the digital outputs (Signal) and the SupervisionBehavior items.

· Automatic server shutdown if the last OPC client disconnects and the server is started with the -embedded option.

WIENER OPCS 3.0.679.0, 2009-02-02

· Server Startup: Race condition between initialization and detection threads fixed.

WIENER OPCS 3.0.677.0, 2009-01-21

· CAN-bus: Detection of failed transmissions (e.g. if no hardware connected to the interface)

WIENER OPCS 3.0.644.0, 2008-12-17

· Delayed client access to finish device detection at server startup.

· Tolerates power supplies connected to UEP6000.exe via RS232

· Improved device detection

· Fix of some race conditions

· Detection of UEP422/UEP4020/UEP5020 power supplies with fan tray CPU H1-5.07.

· Bugfix: SNMP: Write of some integer variables (e.g. channelNumber) have been treated as float and did not work.

WIENER OPCS 3.0.523.0, 2008-04-18

· Documentation updateed.

WIENER OPCS 3.0.514.0, 14 April 2008

· All requested features implemented. Details in the Trac database (trac.wiener-d.com/WienerOPCS)

WIENER OPCS 3.0.498.0, 20 March 2008

· Some additional features implemented. Details in the Trac database (trac.wiener-d.com/WienerOPCS)

WIENER OPCS 3.0.486.0, 11 March 2008

· Implementation of the caching functionality for SNMP devices, too.

WIENER OPCS 3.0.466.0, 08 Ferbruary 2008

· Implementation of the caching functionality: The devices (e.g. crates) reads are no longer controlled by the OPC client configuration, but managed by the OPC server.

WIENER OPCS 2.1.201.0, 02 Mai 2007

· Bugfix: If someone tries to read the output register settings from a crate which doesn't have this option, the server crases.

· Some documentation cleanups.

WIENER OPCS 2.1.197.0, 23 Apr 2007

· Programmable switch on / switch off ramps

· Setting of the (optional) output register

WIENER OPCS 2.0.64.0, 29 Mar 2007

· Bugfix: If a crate is assigned to a not existing CAN-bus interface, the server crashed. Now an error message is writte to the logfile, and the crate is excluded from the namespace.

· Bugfix: If a CANbus request is stopped, some other requests are stopped, too. This caused crashing the server (e.g. during the OPC compliance test with real test items)

· Bugfix: SNMP: Receiving an SNMP answer of an already canceled OPC request caused the server to die.

· Feature: During registration of the OPC server (with the -r, -u command line arguments) no log file is generated, and no configuration file is accessed.

· Feature: If the log files defined in the configuration file are not absolute file names (e.g. \myLogFile or c:\mylogfile), the logfiles are generated below the Windows temporary folder. (Previous behavior: The current directory was used. That was the \windows\system32 if the server was started as service)

WIENER OPCS 2.0.55.0, 27 Feb 2007

· Version control changed to Subversion. In the Major.Minor.Build.Revision nomenclature the "Build" part now is the SVN revision number, and the "Revision" part (which is not retrievable via OPC) is 0 for all released software.

· New compiler version VC 8.0

· Bugfix: The installation program fails with the registration of the server, if the installation path includes blanks (e.g. "C:\Program Files")

· Feature: Only the prerequisites of used network connections (selcted with the TRANSPORT attribute in the configuration file) must be installed. If you are just using CAN-Bus access, Net-Snmp needs not to be installed.

· Doc: SupervisionBehavior differences between PL512 and UEP6 clarified

· Bugfix: PL512: SupervisionBehavior not writable in some situations

· Bugfix: PL508: The Output....Failure... items report the status of that items, and not (as intended) if a failure occured.

· Doc: LocalControlOnly (Inhibit of the remote control) clarified.

· Feature: RestartService.vbs script to restart the server (and read the configuration again)

· Feature: Additional namespace items concerning the CAN-bus interfaces: BaudRate, BusLoad

WIENER OPCS 2.0.0.x, 15 Dec 2006

· Support of Kvaser CAN-bus hardware.

WIENER OPCS 1.1.1.x, 15 Sep 2006

· Full compliant to OPC Data Access 2.05A (Tested with the OPC Compliance Test tool 2.100 Build 1130 from the OPC Foundation)
The issues with the IOPCAsyncIO2 read & write (invalid client handle in test cases 12 and 13) are removed.

WIENER OPCS 1.1.0.x, 27 Feb 2006

· Namespace extension

· Support of the PL512 power supplies via SNMP.

· Perl configuration file generation.

WIENER OPCS 1.0.3.x, 27 Feb 2006

· Implementation of some "Cache-Only" OPC tags (Server.TestObjects.*) for OPC client development.

· Static data is retrieved in the same way as other data from the crates, so this problems are fixed. It belongs to the responibility of the OPC client developer to make sure that collecting static data desn't block the I/O data transfer.

· OPC manual (including namespace and configuration file) as HTML or PDF. (Thanks to www.doxygen.org)

· The Crate.Output.Channel.ChannelNumber.MeasurementTemperature could now be hidden if a digital sensor is existing. The new configuration file attribute "ShowMeasurementTemperature" controls the behaviour.

· Ther child elements of "SupervisionBehaviour" are writable now.

· This is a release-build

WIENER OPCS 1.0.2.x, 25 Oct 2005

· Write errors from OPC server to the crate are now correctly reported to the client as ERROR.

· This version runs as a "Windows Service".

· Additional configuration file items (SNMP.ReadCommunity, SNMP.WriteCommunity)

· Item "SupervisionBehaviour" and child items are now readable.

· Installation / deinstallation with Microsoft Windows Installer (install.msi)

· Additional help & diagnostic output if started with wrong parameters

· Item "System.OnOffCrate" does work, but returns bad status. Bug in RCM firmware. Fixed in RCM 1.0.0.4.

Known Problems:

· Some (static) data is read only once. If there is a communication problem between server and crates, two situations occur:

- Server is starting without crates: The static data is never retrieved. Status is BAD_CONNECTION.

- Crates die after initial communication was OK: Status is GOOD.

WIENER OPCS 1.0.1.x, 2 Oct 2005

Initial version

Known problems:

· Item "System.Status.OutputFailure" does not work (allways FALSE). Bug in RCM firmware. Fixed in RCM 1.0.0.4.

· If the SNMP reports write errors, they are not propably reportet in the OPC client. That may be a client problem. Must be investigated. FIXED in 1.0.2

· SNMP data transfer is not optimized (some data is redundant). OPTIMIZED in 1.0.2

· OPC item "SupervisionBehaviour" not implemented now.

· The start as a service does not work under all conditions. So this version is a normal application. FIXED in 1.0.2

· This version is a "debug" build, to catch possible errors more easy.

CPU Load

Read ALL data of a 12-channel RCM every 500 ms (This is harder than accessing 20 RCMs every 10 seconds, because SNMP communication to different IP addresses is done parallel)

SNMP transfer time: ca. 50 ms

total system load: ~ 10% (Athlon 3000+, 512 MB RAM, some other applications running)

W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:37 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: OPC Namespace Reference

WienerOPCS

OPC Namespace Reference

This is the namespace documentation of the WienerOPCS server.

Node Name

This is the root node of the namespace.

Parent Node

This is the root node of the namespace.

Child Nodes

  • Server
  • Name of the first controlled crate
  • Name of the second controlled crate
  • ...

Node Relation in the Namespace

See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:34 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Server

WienerOPCS » OPC Namespace Reference

Server

This describes all server-related things.

Node Name

Server

Parent Node

root

Child Nodes

  • TestObjects
  • Interfaces

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
UpTime | DATE | R0 | MES | Retrieves the time how long the OPC server has been running.
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:34 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: TestObjects

WienerOPCS » OPC Namespace Reference » Server

TestObjects

The tags of this node are implemented as "cache-only". There is no connection to real (physical connected) hardware.

The intention for this is to give the OPC client developer some test items.

Node Name

TestObjects

Parent Node

Server

Child Nodes

none

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
I1_Cache | I1 | R0, W0 | MES | Test tag for OPC client development.
I2_Cache | I2 | R0, W0 | MES | Test tag for OPC client development.
I4_Cache | I4 | R0, W0 | MES | Test tag for OPC client development.
UI1_Cache | UI1 | R0, W0 | MES | Test tag for OPC client development.
UI2_Cache | UI2 | R0, W0 | MES | Test tag for OPC client development.
UI4_Cache | UI4 | R0, W0 | MES | Test tag for OPC client development.
R4_Cache | R4 | R0, W0 | MES | Test tag for OPC client development.
R8_Cache | R8 | R0, W0 | MES | Test tag for OPC client development.
BOOL_Cache | BOOL | R0, W0 | MES | Test tag for OPC client development.
BSTR_Cache | BSTR | R0, W0 | MES | Test tag for OPC client development.
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.
Since:
This node was implemented in WienerOPCS 1.0.3.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:35 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Interfaces

WienerOPCS » OPC Namespace Reference » Server

Interfaces

This describes all I/O-interface related things.

Node Name

Interfaces

Parent Node

Server

Child Nodes

  • TCPIP
  • CAN0, CAN1, ...
  • Trace

Node Relation in the Namespace

See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:35 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: TCPIP

WienerOPCS » OPC Namespace Reference » Server » Interfaces

TCPIP

The tags of this node reflect TCPIP specific items.

Node Name

TCPIP

Parent Node

Interfaces

Child Nodes

none

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
NumberOfConnectedDevices | R4 | R | MES | The number of connected devices.
MaximumMeasurementPeriode | R4 | R | MES | The maximum time all MEASUREMENT_DATA of all devices is read.
MaximumUserDataPeriode | R4 | R | MES | The maximum time all USER_DATA of all devices is read.
UserDataPriority | R4 | RW | MES | The relation of USER_DATA / MEASUREMENT_DATA i/o operations.
MaximumTransfersPerSecond | R4 | RW | MES | The maximum number of i/o-operations per connected device per second. Zero means no limit.
Transmitted | R4 | R | MES | The total number of transmitted messages.
Received | R4 | R | MES | The total number of received messages.
TransmittedPerSecond | R4 | R | MES | The number of transmitted messages per second.
ReceivedPerSecond | R4 | R | MES | The number of received messages per second.
MaximumWriteQueueEntries | UI4 | R | MES | The maximum number of queued write operations of all devices. Each device has it's own write queue.
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.
Since:
This node was implemented in WienerOPCS 2.1.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:35 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: CAN0, CAN1, ...

WienerOPCS » OPC Namespace Reference » Server » Interfaces

CAN0, CAN1, ...

The tags of this node reflect CAN-bus specific items.

Node Name

CAN0, CAN1, ...

Parent Node

Interfaces

Child Nodes

none

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
BitRate | UI4 | R | MES | The CAN-bus transmission speed (Bits per second).
NumberOfConnectedDevices | R4 | R | MES | The number of connected devices.
MaximumMeasurementPeriode | R4 | R | MES | The maximum time all MEASUREMENT_DATA of all devices is read.
MaximumUserDataPeriode | R4 | R | MES | The maximum time all USER_DATA of all devices is read.
UserDataPriority | R4 | RW | MES | The relation of USER_DATA / MEASUREMENT_DATA i/o operations.
MaximumTransfersPerSecond | R4 | RW | MES | The maximum number of i/o-operations per connected device per second. Zero means no limit.
Transmitted | R4 | R | MES | The total number of transmitted messages.
Received | R4 | R | MES | The total number of received messages.
Retries | R4 | R | MES | The total number of retries.
Failures | R4 | R | MES | The total number of communication failures. Such failure forces a device to be unconnected.
StatisticsPeriod | R4 | RW | MES | The measurement periode for the following items (in seconds).
BusLoad | R4 | R | MES | Estimated bus load (0..100%).
TransmittedPerSecond | R4 | R | MES | The number of transmitted messages per second.
ReceivedPerSecond | R4 | R | MES | The number of received messages per second.
RetriesPerSecond | R4 | R | MES | The number of retries per second.
FailuresPerSecond | R4 | R | MES | The number of communication failures per second.
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.
Since:
This node was implemented in WienerOPCS 2.1.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:35 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Trace

WienerOPCS » OPC Namespace Reference » Server » Interfaces

Trace

This tag makes it possible to change the Trace values through Namespace while the server is running.

Node Name

Trace

Parent Node

Interfaces

Child Nodes

none

Node Relation in the Namespace

Element Attributs
Attribute | Description
TraceErrorLevel | Control of the ERROR trace level bit mask. (0: disable, 1: enable specific messages)
TraceWarningLevel | Control of the WARNING trace level bit mask. (0: disable, 1: enable specific messages)
TraceInfoLevel | Control of the INFO trace level bit mask. (0: disable, 1: enable specific messages)
TraceDebugLevel | Control of the DEBUG trace level bit mask. (0: disable, 1: enable specific messages)
Remarks:
  • For default Trace value settings see Debug and Trace.
  • The default values of the trace variables are read from WienerOPCS.cfg file. It is possible to change this values either through OPC client, during running the server, or editing the WienerOPCS.cfg file, before starting it.
Since:
This feature was added in 4.0.1899.0.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:35 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Crate

WienerOPCS » OPC Namespace Reference

Crate

A crate node contains all configuration data of a single crate. There is one crate node for each power crate controllable by this server.

The crate is identified by its network address. The associated OPC-complient node name is either generated from the IP-address (e.g. IP 127.0.0.1 gets the name 127_0_0_1) or is defined at the Crate part of the configuration file.

Node Name

Any name (Defined at Crate)

Parent Node

root

Child Nodes

  • System
  • Output
  • Signal
  • Sensor
  • FanTray
  • PowerSupply

Node Relation in the Namespace

Properties provided by this node
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the type and network connection of this crate.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:35 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: System

WienerOPCS » OPC Namespace Reference » Crate

System

The system nodes contains global items which relate to the complete crate.

Node Name

System

Parent Node

Crate

Child Nodes

  • Status

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
Description | BSTR | R0 | FIX | A textual description of the connected crate and its firmware. Example: "WIENER Crate (RCM 1.0.0.1)"
OnOff | BOOL | W1 | USR | FALSE: Switch off and lock all channels of the power supply. TRUE: Unlock. Channels may be switched on by other commands.
NetworkAddress | BSTR | R0 | FIX | Retrieves the dotted-decimal IP address actually used by the connected device.
NetworkAddressStatic | BSTR | R0 | USR | Retrieves the dotted-decimal IP address assigned to the connected device. The special value 0.0.0.0 is used if BOOTP/DHCP is activated.
UpTime | DATE | R0 | MES | Retrieves the time how long the crate has been running.
UserBusReset | BOOL | W1 | USR | VME: Generate a VME SYSRESET.
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.

UpTime

Remarks:
Not available if connected via CAN-bus.

NetworkAddressStatic

Limitations:
Only available if connected via TCPIP.
Since:
WienerOPCS 3.0.1142.0.

NetworkAddress

Limitations:
Only available if connected via TCPIP.
Since:
WienerOPCS 3.0.1142.0.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:35 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Status

WienerOPCS » OPC Namespace Reference » Crate » System

Status

Global status of the complete crate.

Node Name

Status

Parent Node

System

Child Nodes

none

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
On | BOOL | R0 | MES | FALSE: All channels of the power supply are switched off and locked. TRUE: Channels may be switched on by other commands.
Inhibit | BOOL | R0 | MES | FALSE: All channels of the power supply are switched off and locked by an inhibit/interlock signal. TRUE: Channels may be switched on by other commands.
FailureInput | BOOL | R0 | MES | Failure of the device supply voltage (e.g. AC mains).
FailureOutput | BOOL | R0 | MES | FALSE: All output channels are OK. TRUE: At least one output failure.
FailureSystem | BOOL | R0 | MES | Any global system failure (e.g. selftest failure).
FailureFanTray | BOOL | R0 | MES | True if one fan is broken.
FailureSensor | BOOL | R0 | MES | At least one of the temperature sensors connected to the temperature branch has a failure.
FailureSignal | BOOL | R0 | MES | At least one of the items connected to the signal branch has a failure.
FailureUserBus | BOOL | R0 | MES | VME: The SYSFAIL signal.
WriteProtect | BOOL | R0 | MES | True if SYSTEM_DATA is write-protected.
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:35 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Output

WienerOPCS » OPC Namespace Reference » Crate

Output

This node contains all output-relevant items.

Node Name

Output

Parent Node

Crate

Child Nodes

  • Channel
  • Group

Node Relation in the Namespace

See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:37 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Channel

WienerOPCS » OPC Namespace Reference » Crate » Output

Channel

This node contains a child node for each crate channel.

Node Name

Channel

Parent Node

Output

Child Nodes

  • 0
  • 1
  • . . .

Node Relation in the Namespace

See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:37 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Channel Number

WienerOPCS » OPC Namespace Reference » Crate » Output » Channel

Channel Number

This node contains all data of a single output channel.

Node Name

Channel Number

Parent Node

Channel

Child Nodes

  • Status
  • SupervisionBehavior

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
Name | BSTR | R0 | SYS | A textual description of the channel.
OnOff | BOOL | W1 |  | FALSE: Switch this channel off. This clears all error flags. TRUE: Switch this channel on.
ClearEvents | BOOL | W1 |  | Clear all (error) event flags of this channel. It is necessary to clear events before a channel can be switched on again. This is used by MPOD HV modules only.
Voltage | R4 | R0. W3 | USR | Nominal output voltage [V]. The power supply regulates the voltage at the sense connection to this value.
VoltageFineAdjust | R4 | R0. W3 | USR | Adjustment of Voltage in small steps, to get a higher resolution. The value is different from device to device. If the device is replaced by an identical one (e.g. in case of hardware failure), the adjustment has to be done again.
Current | R4 | R0, W3 | USR | Current limit [A]. If the output current grows to this value, the power supply will switch to constant current mode (and the sense voltage will decrease below Voltage).
MeasurementSenseVoltage | R4 | R0 | MES | Measured voltage at the sense point [V].
MeasurementTerminalVoltage | R4 | R0 | MES | Measured voltage at the sense point [V].
MeasurementCurrent | R4 | R0 | MES | Measured output current [A].
MeasurementTemperature | I2 | R0 | MES | Retrieves the measured temperature of the power supply module [°C].
SupervisionMaxCurrent | R4 | R0, W2 | USR | Maximum allowed current for good status [A].
SupervisionMinSenseVoltage | R4 | R0, W2 | USR | Minimum allowed sense voltage for good status [V].
SupervisionMaxSenseVoltage | R4 | R0, W2 | USR | Maximum allowed sense voltage for good status [V].
SupervisionMaxTerminalVoltage | R4 | R0, W2 | USR | Maximum allowed terminal voltage for good status [V].
SupervisionMaxTemperature | R4 | R0, W2 | USR | Maximum allowed power supply module termperature for good status [°C].
SupervisionMaxPower | R4 | R0, W2 | USR | Maximum allowed output power for good status [W].
GroupNumber | I2 | R0, W2 | USR | Group number of this channel. (1...127)
VoltageRiseRate | R4 | R0, W3 | USR | Voltage Rise Slew Rate [V/s]. The slew rate of the output voltage if it increases (after switch on or if the Voltage has been changed)
VoltageFallRate | R4 | R0, W3 | USR | Voltage Fall Slew Rate [V/s]. The slew rate of the output voltage if it decreases (after switch off or if the Voltage has been changed)
RegulationMode | I2 | R0, W3 | USR | Regulation mode. This enumerator should be set according to the load cable length. 0: Fast regulation, short cables. 1: Moderate regulation, medium cables. 2: Slow regulation, long cables.
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.

Name

Limitations:
Only available if connected via TCPIP.
Since:
WienerOPCS 1.1.0.

OnOff

Limitations:
Only available if the crate type is RCM, PL512 or MPOD.

ClearEvents

Limitations:
Only available if the crate type is MPOD with HV-modules.

Voltage

Properties:
  • High EU (property ID 102)
    Constant value 8.
  • Low EU (property ID 103)
    Constant value 0.
Limitations:
Only available if the crate type is PL508 or PL512.
Since:
WienerOPCS 1.1.0.

Current

Properties:
  • High EU (property ID 102)
    Constant value 8.
  • Low EU (property ID 103)
    Constant value 0.
Limitations:
Only available if the crate type is PL508 or PL512.
Since:
WienerOPCS 1.1.0.

MeasurementSenseVoltage

Properties:
  • High EU (property ID 102)
    Constant value 8.
  • Low EU (property ID 103)
    Constant value 0.

MeasurementTerminalVoltage

Properties:
  • High EU (property ID 102)
    Constant value 8.
  • Low EU (property ID 103)
    Constant value 0.
Limitations:
Only available if the crate type is PL512
Since:
WienerOPCS 1.1.0.

MeasurementCurrent

Properties:
  • High EU (property ID 102)
    Constant value 100.
  • Low EU (property ID 103)
    Constant value 0.

MeasurementTemperature

If the hardware is not able to measure analog temperatures (digital temperature switch), special values are returned:
  • -32768: Temperature is below the critical limit.
  • +32767: Temperature is above the critical limit.

It is possible to remove this tag from the namespace, if no analog tempearture is available. See Crates for details.

Properties:
  • High EU (property ID 102)
    Constant value 125.
  • Low EU (property ID 103)
    Constant value 0.
Limitations:
Only available if the crate type is PL508 or PL512

SupervisionMaxCurrent

Properties:
  • High EU (property ID 102)
    Constant value 100.
  • Low EU (property ID 103)
    Constant value 0.

SupervisionMinSenseVoltage

Properties:
  • High EU (property ID 102)
    Constant value 8.
  • Low EU (property ID 103)
    Constant value 0.
Since:
WienerOPCS 1.1.0.

SupervisionMaxSenseVoltage

Properties:
  • High EU (property ID 102)
    Constant value 8.
  • Low EU (property ID 103)
    Constant value 0.

SupervisionMaxTerminalVoltage

Properties:
  • High EU (property ID 102)
    Constant value 8.
  • Low EU (property ID 103)
    Constant value 0.
Limitations:
Only available if the crate type is PL508 or PL512
Since:
WienerOPCS 1.1.0.

SupervisionMaxTemperature

Properties:
  • High EU (property ID 102)
    Constant value 8.
  • Low EU (property ID 103)
    Constant value 0.
Limitations:
Only available if the crate type is PL512
Since:
WienerOPCS 3.0.1140.0.

SupervisionMaxPower

Properties:
  • High EU (property ID 102)
    Constant value 1000.
  • Low EU (property ID 103)
    Constant value 0.
Limitations:
Only available if the crate type is PL512
Since:
WienerOPCS 1.1.0.

GroupNumber

Limitations:
Only available if connected via TCPIP.

VoltageRiseRate

Properties:
  • High EU (property ID 102)
    Constant value 65535.
  • Low EU (property ID 103)
    Constant value 0.
Limitations:
Only available if the crate type is PL512
Since:
WienerOPCS 2.1.58.0

VoltageFallRate

Properties:
  • High EU (property ID 102)
    Constant value 65535.
  • Low EU (property ID 103)
    Constant value 0.
Limitations:
Only available if the crate type is PL512
Since:
WienerOPCS 2.1.58.0

RegulationMode

Properties:
  • High EU (property ID 102)
    Constant value 3.
  • Low EU (property ID 103)
    Constant value 0.
Limitations:
Only available if the crate type is PL512
Since:
WienerOPCS 3.0.1141.0
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:37 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Status

WienerOPCS » OPC Namespace Reference » Crate » Output » Channel » Channel Number

Status

Status of this channel.

Node Name

Status

Parent Node

Channel Number

Child Nodes

none

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
On | BOOL | R0 | MES | FALSE: Channel is off. TRUE: Channel is on.
Inhibit | BOOL | R0 | USR | FALSE: Channel can be switched on. TRUE: Channel can not be switched on.
RampUp | BOOL | R0 | USR | FALSE: Voltage is not rising. TRUE: Voltage is rising (because of switch on or voltage change).
RampDown | BOOL | R0 | USR | FALSE: Voltage is not falling. TRUE: Voltage is falling (because of switch off or voltage change).
FailureMinSenseVoltage | BOOL | R0 | MES | FALSE: OK TRUE: Sense voltage too low.
FailureMaxSenseVoltage | BOOL | R0 | MES | FALSE: OK TRUE: Sense voltage too high.
FailureMaxTerminalVoltage | BOOL | R0 | MES | FALSE: OK TRUE: Terminal voltage too high.
FailureMaxCurrent | BOOL | R0 | MES | FALSE: OK TRUE: Output current too high.
FailureMaxTemperature | BOOL | R0 | MES | FALSE: OK TRUE: Temperature failure.
FailureMaxPower | BOOL | R0 | MES | FALSE: OK TRUE: Output power too high.
FailureTimeout | BOOL | R0 | MES | FALSE: OK TRUE: Communication timeout between power module and the control.
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.

Inhibit

Since:
WienerOPCS 1.1.0.

RampUp

Remarks:
Not available if connected via CAN-bus.
Since:
WienerOPCS 1.1.0.

RampDown

Remarks:
Not available if connected via CAN-bus.
Since:
WienerOPCS 1.1.0.

FailureMinSenseVoltage

Since:
WienerOPCS 1.1.0.

FailureMaxPower

Remarks:
Not available if connected via CAN-bus.
Since:
WienerOPCS 1.1.0.

FailureTimeout

Remarks:
Not available if connected via CAN-bus.
Since:
WienerOPCS 1.1.0.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:37 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: SupervisionBehavior

WienerOPCS » OPC Namespace Reference » Crate » Output » Channel » Channel Number

SupervisionBehavior

Supervision Behavior of this Channel.

If a supervision threshold is exceeded, the behavior is selectable:

  • The failure can be ignored.
    This is usefull for tests and the implementation phase, but not recommendet for normal operation.
  • Switch this channel off.
    This is the standard action for stand-allone channels.
  • Switch all channels belonging to the channel group off.
    If a specific electronic is supplied by more than one channels (e.g. 5V and 3.3V), it may be usefull to switch off all the supplying outputs on a failure.
  • Switch all channels of the power supply off.
    This is usefull if parameters, which affect all outputs, are affected. (E.g module temperature)

To prevent damage to the power supply itself, some selections are not allowed for certain items.

Limitations:
Only available if the crate type is RCM or PL512.

Node Name

SupervisionBehavior

Parent Node

Channel Number

Child Nodes

none

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
MinSenseVoltage | I2 | R0, W2 | USR | Enumerated value: 0: Ignore the failure. 1: Switch this channel off. 2: Switch all channels belonging to the channel group off. 3: Switch all channels of the power supply off.
MaxSenseVoltage | I2 | R0, W2 | USR | Enumerated value: 0: Ignore the failure. 1: Switch this channel off. 2: Switch all channels belonging to the channel group off. 3: Switch all channels of the power supply off.
MaxTerminalVoltage | I2 | R0, W2 | USR | Enumerated value: 1: Switch this channel off. 2: Switch all channels belonging to the channel group off. 3: Switch all channels of the power supply off.
MaxCurrent | I2 | R0, W2 | USR | Enumerated value: 0: Ignore the failure. 1: Switch this channel off. 2: Switch all channels belonging to the channel group off. 3: Switch all channels of the power supply off.
MaxTemperature | I2 | R0, W2 | USR | Enumerated value: 1: Switch this channel off. 2: Switch all channels belonging to the channel group off. 3: Switch all channels of the power supply off.
MaxPower | I2 | R0, W2 | USR | Enumerated value: 1: Switch this channel off. 2: Switch all channels belonging to the channel group off. 3: Switch all channels of the power supply off.
Timeout | I2 | R0, W2 | USR | Enumerated value: 0: Ignore the failure. 1: Switch this channel off. 2: Switch all channels belonging to the channel group off. 3: Switch all channels of the power supply off.
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.
Since:
The write functionality was implemented in WienerOPCS 1.0.3.

MinSenseVoltage

Since:
WienerOPCS 1.1.0.

MaxPower

Since:
WienerOPCS 1.1.0.

Timeout

Since:
WienerOPCS 1.1.0.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:37 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Group

WienerOPCS » OPC Namespace Reference » Crate » Output

Group

This node contains a child node for each channel group. The special group with the name "ALL" contains all existing output channels.

Node Name

Group

Parent Node

Output

Child Nodes

  • ALL
  • 1
  • 2
  • . . .

Node Relation in the Namespace

Remarks:
Not available if connected via CAN-bus.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:37 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Group Number

WienerOPCS » OPC Namespace Reference » Crate » Output » Group

Group Number

This node contains all items related to all channels of this specific output group.

Node Name

ALL or Group Number

Parent Node

Group

Child Nodes

none

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
OnOff | BOOL | W1 |  | FALSE: Switch all channels of this group off. This clears all error flags. TRUE: Switch this channels of this group on.
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.
Remarks:
Not available if connected via CAN-bus.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:37 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Signal

WienerOPCS » OPC Namespace Reference » Crate

Signal

This node contains all special signals.

Node Name

Signal

Parent Node

Crate

Child Nodes

  • Digital Outputs

Node Relation in the Namespace

Since:
This is planned to be implemented and nor realized in this server version.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:36 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Digital Outputs

WienerOPCS » OPC Namespace Reference » Crate » Signal

Digital Outputs

This node contains all digital output signals.

Node Name

DigitalOutputs

Parent Node

Signal

Child Nodes

  • none

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
0 1 ... 31 | BOOL | RW | USR | FALSE: The output register bit is set to 0 (no inhibit). TRUE: The output register bit is set to 1 (inhibit).
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.
Limitations:
Only available if the crate type is PL508_DO (PL508 with the "Output Register" option).
Since:
This is planned to be implemented and not realized in this server version.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:36 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Sensor

WienerOPCS » OPC Namespace Reference » Crate

Sensor

This node contains all special signals.

Node Name

Sensor

Parent Node

Crate

Child Nodes

  • Temperature

Node Relation in the Namespace

See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:36 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Temperature

WienerOPCS » OPC Namespace Reference » Crate » Sensor

Temperature

This node contains a child node for each temperature channel.

Node Name

Channel Number

Parent Node

Sensor

Child Nodes

  • 0
  • 1
  • . . .
  • 7

Node Relation in the Namespace

See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:36 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Channel Number

WienerOPCS » OPC Namespace Reference » Crate » Sensor » Temperature

Channel Number

This node contains all data of one temperature channel.

Node Name

Channel Number

Parent Node

Temperature

Child Nodes

none

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
MeasurementTemperaturee | R4 | R0 | MES | The external sensor temperature[°C].
SupervisionWarnTemperature | R4 | R0, W2 | USR | If this temperature is exceeded, the fan tray switches to full speed.
SupervisionMaxTemperature | R4 | R0, W2 | USR | If this temperature is exceeded, all outputs are switched off.
FailureMaxTemperature | R4 | R0, W2 | MES | The temperature sensor has reached the SupervisionMaxTemperature threshold.
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:36 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: FanTray

WienerOPCS » OPC Namespace Reference » Crate

FanTray

This node contains all fan-specific items.

Node Name

FanTray

Parent Node

Crate

Child Nodes

  • 0
  • 1
  • . . .

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
FanSpeed | R4 | R0, W2 | USR | The nominal fan speed of all fans [RPM].
MeasurementFanSpeed | R4 | R0 | MES | The average fan speed [RPM].
TripIfFanFailure | BOOL | R0 | USR | If true, all output channels will be switched off in case of a fan failure.
OpeartingTime | DATE | R0 | MES | The fan operating time (incremented if the fans are running).
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:36 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Fan Number

WienerOPCS » OPC Namespace Reference » Crate » FanTray

Fan Number

This node contains all data of a specific fan.

Node Name

Fan Number

Parent Node

FanTray

Child Nodes

none

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
MeasurementFanSpeed | R4 | R0 | MES | The fan speed [RPM].
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:36 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: PowerSupply

WienerOPCS » OPC Namespace Reference » Crate

PowerSupply

This node contains all power supply specific items.

Node Name

FanTray

Parent Node

Crate

Child Nodes

none

Node Relation in the Namespace

Tags

Tag Name | Data Type | Access Level | Update Rate | Description
OpeartingTime | DATE | R0 | MES | The power supply operating time (incremented if the outputs are switched on).
Properties provided by all tags
  • Item Description (property ID 101)
    This property retrieves a constant help text which describes the function and usage of the tag.
See also:
OPC Namespace Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:36 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Namespace Tree

WienerOPCS

Namespace Tree

 |  |  |  |  |  |  | Read or Write Access | Data Type | MARATON Remote Controller (TCP/IP) | PL512, Mpod (TCP/IP) | PL508 with TCP/IP Power Bin | PL508 (CAN) | PL508 with Output Register (CAN) | VME-Crates V6 (TCP/IP) | VME-Crates V6 (CAN) | VME-Crates V4/V5 (CAN) | Reserved for Future Devices
Server |  |  |  |  |  |  |  |  | x | x | x | x | x | x | x | x |
 | UpTime |  |  |  |  |  | R | DATE | x | x | x | x | x | x | x | x |
 | Interfaces |  |  |  |  |  |  |  |  |  |  | x | x |  | x | x |
 |  | CAN0, CAN1, ... |  |  |  |  |  |  |  |  |  | x | x |  | x | x |
 |  |  | BitRate |  |  | Bus speed (in bits/second) | R | I4 |  |  |  | x | x |  | x | x |
 |  |  | NumberOfConnectedDevices |  |  | The number of the configured devices which are really connected. | R | I4 |  |  |  | x | x |  | x | x |
 |  |  | MaximumMeasurementPeriod |  |  | The maximum time all MEASUREMENT_DATA of all devices is read (in seconds). | R | R4 |  |  |  | x | x |  | x | x |
 |  |  | MaximumUserDataPeriod |  |  | The maximum time all USER_DATA of all devices is read (in seconds). | R | R4 |  |  |  | x | x |  | x | x |
 |  |  | UserDataPriority |  |  | The relation of USER_DATA to MEASUREMENT_DATA i/o operations | RW | R4 |  |  |  | x | x | x | x | x |
 |  |  | MaximumTransfersPerSecond |  |  | The maximum number of i/o-operations per connected device per second. Zero means no limit. | RW | R4 |  |  |  | x | x | x | x | x |
 |  |  | Transmitted |  |  | Total number of transmitted CAN messages | R | I4 |  |  |  | x | x |  | x | x |
 |  |  | Received |  |  | Total number of received CAN messages. | R | I4 |  |  |  | x | x |  | x | x |
 |  |  | Retries |  |  | Total number of CAN retries. | R | I4 |  |  |  | x | x |  | x | x |
 |  |  | Failures |  |  | Total number of communication failures. | R | I4 |  |  |  | x | x |  | x | x |
 |  |  | StatisticsPeriod |  |  | The measurement periode for the following items (in seconds). | RW | R4 |  |  |  | x | x |  | x | x |
 |  |  | BusLoad |  |  | 0..100% | R | R8 |  |  |  | x | x |  | x | x |
 |  |  | TransmittedPerSecond |  |  |  | R | R8 |  |  |  | x | x |  | x | x |
 |  |  | ReceivedPerSecond |  |  |  | R | R8 |  |  |  | x | x |  | x | x |
 |  |  | RetriesPerSecond |  |  |  | R | R8 |  |  |  | x | x |  | x | x |
 |  |  | FailuresPerSecond |  |  |  | R | R8 |  |  |  | x | x |  | x | x |
 |  | TCP/IP |  |  |  |  |  |  | x | x | x |  |  | x |  |  |
 |  |  | NumberOfConnectedDevices |  |  | The number of the configured devices which are really connected. | R | I4 | x | x | x |  |  | x |  |  |
 |  |  | MaximumMeasurementPeriod |  |  | The maximum time all MEASUREMENT_DATA of all devices is read (in seconds). | R | R4 | x | x | x |  |  | x |  |  |
 |  |  | MaximumUserDataPeriod |  |  | The maximum time all USER_DATA of all devices is read (in seconds). | R | R4 | x | x | x |  |  | x |  |  |
 |  |  | UserDataPriority |  |  | The relation of USER_DATA to MEASUREMENT_DATA i/o operations | RW | R4 | x | x | x |  |  | x |  |  |
 |  |  | MaximumTransfersPerSecond |  |  | The maximum number of i/o-operations per connected device per second. Zero means no limit. | RW | R4 | x | x | x |  |  | x |  |  |
 |  |  | Transmitted |  |  | Total number of transmitted SNMP messages | R | I4 | x | x | x |  |  | x |  |  |
 |  |  | Received |  |  | Total number of received SNMP messages. | R | I4 | x | x | x |  |  | x |  |  |
 |  |  | TransmittedPerSecond |  |  |  | R | R8 | x | x | x |  |  | x |  |  |
 |  |  | ReceivedPerSecond |  |  |  | R | R8 | x | x | x |  |  | x |  |  |
 | TestObjects |  |  |  |  |  |  |  | x | x | x | x | x | x | x | x |
 |  | BOOL_Cache |  |  |  |  | RW | BOOL | x | x | x | x | x | x | x | x |
 |  | BSTR_Cache |  |  |  |  | RW | BSTR | x | x | x | x | x | x | x | x |
 |  | I1_Cache |  |  |  |  | RW | I1 | x | x | x | x | x | x | x | x |
 |  | I2_Cache |  |  |  |  | RW | I2 | x | x | x | x | x | x | x | x |
 |  | I4_Cache |  |  |  |  | RW | I4 | x | x | x | x | x | x | x | x |
 |  | R4_Cache |  |  |  |  | RW | R4 | x | x | x | x | x | x | x | x |
 |  | R8_Cache |  |  |  |  | RW | R8 | x | x | x | x | x | x | x | x |
 |  | UI1_Cache |  |  |  |  | RW | UI1 | x | x | x | x | x | x | x | x |
 |  | UI2_Cache |  |  |  |  | RW | UI2 | x | x | x | x | x | x | x | x |
 |  | UI4_Cache |  |  |  |  | RW | UI4 | x | x | x | x | x | x | x | x |
Crate1, ... |  |  |  |  |  | The item name may be any text string |  |  | x | x | x | x | x | x | x | x |
 | System |  |  |  |  |  |  |  | x | x | x | x | x | x | x | x |
 |  | Description |  |  |  |  | R | BSTR | x | x | x | x | x | x | x | x |
 |  | OnOff |  |  |  |  | W | BOOL | x | x | x | x | x | x | x | x |
 |  | UpTime |  |  |  |  | R | DATE | x | x | x | x | x | x | x | x |
 |  | NetworkAddress |  |  |  | Retrieves the dotted-decimal IP address actually used by the connected device | R | BSTR | x | x | x |  |  | x |  |  |
 |  | NetworkAddressStatic |  |  |  | Retrieves the dotted-decimal IP address assigned to the connected device.The special value 0.0.0.0 is used if BOOTP/DHCP is activated | R | BSTR |  | x |  |  |  |  |  |  |
 |  | UserBusReset |  |  |  | The special value 0.0.0.0 is used if BOOTP/DHCP is activated. | W | BOOL |  |  |  |  |  | x | x | x |
 |  | Status |  |  |  |  |  |  | x | x | x | x | x | x | x | x |
 |  |  | On |  |  |  | R | BOOL | x | x | x | x | x | x | x | x |
 |  |  | Inhibit |  |  |  | R | BOOL |  | x | x | x | x | x | x | x |
 |  |  | FailureInput |  |  |  | R | BOOL |  |  | x | x | x | x | x | x |
 |  |  | FailureOutput |  |  |  | R | BOOL | x | x | x | x | x | x | x | x |
 |  |  | FailureSystem |  |  |  | R | BOOL |  |  |  | x | x |  | x | x |
 |  |  | FailureFanTray |  |  | True if one fan is broken. | R | BOOL |  |  |  |  |  | x | x | x |
 |  |  | FailureSensor |  |  | At least one of the temperature sensors connected to the temperature branch has a failure. | R | BOOL |  |  | x | x | x | x | x |  |
 |  |  | FailureSignal |  |  | At least one of the items connected to the signal branch has a failure. | R | BOOL |  |  |  |  |  |  |  |  | x
 |  |  | FailureUserBus |  |  | VME: The SYSFAIL signal | R | BOOL |  |  |  |  |  | x | x | x |
 |  |  | WriteProtect |  |  | True if SYSTEM_DATA is write-protected | R | BOOL |  |  |  | x | x |  | x | x |
 | Input |  |  |  |  | Future: This branch may contain mains input temperature, voltage, ... |  |  |  |  |  |  |  |  |  |  | x
 | Output |  |  |  |  |  |  |  | x | x | x | x | x | x | x | x |
 |  | Channel |  |  |  |  |  |  | x | x | x | x | x | x | x | x |
 |  |  | 0, 1, 2, ... |  |  | The item name corresponds to the hardware channel numbers. |  |  | x | x | x | x | x | x | x | x |
 |  |  |  | Name |  |  | RW | BSTR | x | x | x |  |  | x |  |  |
 |  |  |  | Voltage |  |  | RW | R4 |  | x | x | x | x | x | x | x |
 |  |  |  | VoltageFineAdjust |  | Adjustment of Voltage in small steps, to get a higher resolution. The value is different from device to device. If the device is replaced by an identical one (e.g. in case of hardware failure), the adjustment has to be done again. | RW | I1 |  |  | x | x | x | x | x |  |
 |  |  |  | Current |  |  | RW | R4 |  | x | x | x | x | x | x | x |
 |  |  |  | MeasurementCurrent |  |  | R | R4 | x | x | x | x | x | x | x | x |
 |  |  |  | MeasurementSenseVoltage |  |  | R | R4 | x | x | x | x | x | x | x | x |
 |  |  |  | MeasurementTerminalVoltage |  |  | R | R4 |  | x |  |  |  |  |  |  |
 |  |  |  | MeasurementTemperature |  | Power module temperature | R | R4 |  | x |  |  |  |  |  |  |
 |  |  |  | SupervisionMaxCurrent |  |  | RW | R4 | x | x | x | x | x | x | x | x |
 |  |  |  | SupervisionMaxSenseVoltage |  |  | RW | R4 | x | x | x | x | x | x | x | x |
 |  |  |  | SupervisionMaxTerminalVoltage |  |  | RW | R4 |  | x | x | x | x | x | x |  |
 |  |  |  | SupervisionMinSenseVoltage |  |  | RW | R4 | x | x | x | x | x | x | x | x |
 |  |  |  | SupervisionMaxPower |  |  | RW | R4 | x | x |  |  |  |  |  |  |
 |  |  |  | SupervisionMaxTemperature |  | Maximum allowed power supply module termperature for good status [°C]. | RW | R4 |  | x |  |  |  |  |  |  |
 |  |  |  | VoltageFallRate |  |  | RW | R4 |  | x |  |  |  |  |  |  |
 |  |  |  | VoltageRiseRate |  |  | RW | R4 |  | x |  |  |  |  |  |  |
 |  |  |  | RegulationMode |  |  | RW | I2 |  | x |  |  |  |  |  |  |
 |  |  |  | OnOff |  |  | W | BOOL | x | x |  |  |  |  |  |  |
 |  |  |  | GroupNumber |  |  | RW | I2 | x | x |  |  |  |  |  |  |
 |  |  |  | Status |  |  |  |  | x | x | x | x | x | x | x | x |
 |  |  |  |  | On |  | R | BOOL | x | x |  |  |  |  |  |  |
 |  |  |  |  | Inhibit |  | R | BOOL |  | x |  |  |  |  |  |  |
 |  |  |  |  | RampUp |  | R | BOOL |  | x |  |  |  |  |  |  |
 |  |  |  |  | RampDown |  | R | BOOL |  | x |  |  |  |  |  |  |
 |  |  |  |  | FailureMaxCurrent |  | R | BOOL | x | x | x | x | x | x | x | x |
 |  |  |  |  | FailureMaxSenseVoltage |  | R | BOOL | x | x | x | x | x | x | x | x |
 |  |  |  |  | FailureMaxTerminalVoltage |  | R | BOOL |  | x | x | x | x | x | x | x |
 |  |  |  |  | FailureMinSenseVoltage |  | R | BOOL | x | x | x | x | x | x | x | x |
 |  |  |  |  | FailureMaxTemperature |  | R | BOOL | x | x | x | x | x | x | x | x |
 |  |  |  |  | FailureMaxPower |  | R | BOOL | x | x |  |  |  |  |  |  |
 |  |  |  |  | FailureTimeout | If the power module has no communication to it's local controllerr (both boards are inside of a PL512 power supply), a timeout occurs | R | BOOL | x | x |  |  |  |  |  |  |
 |  |  |  | SupervisionBehavior |  |  |  |  | x | x |  |  |  |  |  |  |
 |  |  |  |  | MinSenseVoltage |  | RW | I2 | x | x |  |  |  |  |  |  |
 |  |  |  |  | MaxSenseVoltage |  | RW | I2 | x | x |  |  |  |  |  |  |
 |  |  |  |  | MaxTerminalVoltage |  | RW | I2 | x | x |  |  |  |  |  |  |
 |  |  |  |  | MaxCurrent |  | RW | I2 | x | x |  |  |  |  |  |  |
 |  |  |  |  | MaxPower |  | RW | I2 | x | x |  |  |  |  |  |  |
 |  |  |  |  | MaxTemperature |  | RW | I2 | x | x |  |  |  |  |  |  |
 |  |  |  |  | Timeout | see Status.FailureTimeout | RW | I2 | x | x |  |  |  |  |  |  |
 |  | Group |  |  |  |  |  |  | x | x |  |  |  |  |  |  |
 |  |  | ALL, 1, 2, ... |  |  |  |  |  | x | x |  |  |  |  |  |  |
 |  |  |  | OnOff |  |  | W | BOOL | x | x |  |  |  |  |  |  |
 | Signal |  |  |  |  |  |  |  |  |  |  |  | x |  |  |  |
 |  | DigitalOutput |  |  |  |  |  |  |  |  |  |  | x |  |  |  |
 |  |  | 0, 1, 2, ... |  |  |  | RW | BOOL |  |  |  |  | x |  |  |  |
 |  | DigitalInput |  |  |  |  |  |  |  |  |  |  |  |  |  |  | x
 |  |  | 0, 1, 2, ... |  |  |  | R | BOOL |  |  |  |  |  |  |  |  | x
 |  | AnalogInput |  |  |  |  |  |  |  |  |  |  |  |  |  |  | x
 |  |  | 0, 1, 2, ... |  |  |  | R | R4 |  |  |  |  |  |  |  |  | x
 | Sensor |  |  |  |  |  |  |  |  |  | x | x | x | x | x |  |
 |  | Temperature |  |  |  |  |  |  |  |  | x | x | x | x | x |  |
 |  |  | 0, 1, 2, ... |  |  |  |  |  |  |  | x | x | x | x | x |  |
 |  |  |  | MeasurementTemperature |  |  | R | R4 |  |  | x | x | x | x | x |  |
 |  |  |  | SupervisionWarnTemperature |  |  | RW | R4 |  |  |  |  |  | x | x |  |
 |  |  |  | SupervisionMaxTemperature |  |  | RW | R4 |  |  | x | x | x | x | x |  |
 |  |  |  | FailureMaxTemperature |  | True if the temperature sensor has reached the SupervisionMaxTemperature threshold. | R | BOOL |  |  |  | x | x |  | x |  |
 | FanTray |  |  |  |  |  |  |  |  |  |  |  |  | x | x | x |
 |  | FanSpeed |  |  |  |  | RW | R4 |  |  |  |  |  | x | x | x |
 |  | MeasurementFanSpeed |  |  |  | The average fan speed of all fans | R | R4 |  |  |  |  |  | x | x | x |
 |  | TripIfFanFailure |  |  |  |  | R | BOOL |  |  |  |  |  |  | x | x |
 |  | OperatingTime |  |  |  |  | R | DATE |  |  |  |  |  | x | x | x |
 |  | 0, 1, 2, ... |  |  |  | One node for each fan |  |  |  |  |  |  |  | x | x | x |
 |  |  | MeasurementFanSpeed |  |  | The speed of each fan | R | R4 |  |  |  |  |  | x | x | x |
 | PowerSupply |  |  |  |  |  |  |  | x | x | x | x | x | x | x |  |
 |  | OperatingTime |  |  |  |  | R | DATE | x | x | x | x | x | x | x |  |
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:37 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Special Requirements for the WienerOPCS Server

WienerOPCS

Special Requirements for the WienerOPCS Server

Update Rate

The update rate is the time period after all tag objects of an OPC group are reloaded.

This forces the OPC server to retrieve the data from the connected hardware. This is done in any case (even if the OPC server 'knows' that the data will never change, e.g. the serial number of a connected hardware) to give the client the opportunity to verify the hardware data.

There is a server-wide minimal update rate (0.5 seconds) for all OPC items, but if a client tries to retrieve all possible tags with this update rate, this will generate massive network traffic between the server and the connected hardware. So it is possible that the OPC quality of some items changes to BAD "(not connected)".

All OPC item tags are assigned to the following classes:

MES: Measurement Data

This data is generated by the hardware dynamically and may change at any time.

Examples for this are UpTime or MeasurementCurrent.

USR: User Data

This data is stored in a hardware flash/eeprom. The data can be modified by the user during normal operation (e.g. with manual switches at the front pannel or via OPC)

An example for this is SupervisionMaxCurrent.

SYS: System Data

This data is stored in a special hardware flash/eeprom section. The data can not be modified by the user during normal operation, but can be changed by the manufacturer.

FIX: Fix Data

This data is stored in the firmware flash of the hardware and will only change during firmware update. It will never change during the time the hardware is connected to the OPC server.

An example for this is Description.

W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:37 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Configuration File Reference

WienerOPCS

Configuration File Reference

The configuration file "WienerOPCS.cfg" is used to configure the server. The file is a text file, formatted in XML, with the root element WienerOPCS.

The file WienerOPCS.cfg ist installed in the WienerOPCS directory during the first installation. This file must be edited to match the local system, and will not be overwritten during succeeding installations.

The file WienerOPCS.template.cfg file contains all possible configuration elements.

The configuration file "WienerOPCS.cfg" is searched in the following directories in the following sequence:

  1. The directory from which the application loaded.
  2. The current directory.
  3. The system directory.
  4. The 16-bit system directory.
  5. The Windows directory.
  6. The directories that are listed in the PATH environment variable.
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:37 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: WienerOPCS

WienerOPCS » Configuration File Reference

WienerOPCS

Element Name
WienerOPCS
Element Attributs
Attribute | Default | Description
version | 1.0 | version of the configuration file syntax
date | 20051101 | the last modification date (YYYYMMDD)
time | 124500 | the last modification time (HHMMSS)
Parent Element
This is the root element of the configuration file.
Child Elements
  • Debug - Debug and trace
  • SNMP
  • CAN
  • Crates - Collection of all crates controlled by this server
Element Relation
Remarks:
The configuration file "WienerOPCS.cfg" is searched in the following directories in the following sequence:
  1. The directory from which the server application loaded.
  2. The current directory.
  3. The system directory.
  4. The 16-bit system directory.
  5. The Windows directory.
  6. The directories that are listed in the PATH environment variable.
See also:
Configuration File Element Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:38 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Debug and Trace

WienerOPCS » Configuration File Reference » WienerOPCS

Debug and Trace

All debug and trace-specific items.

Element Name
Debug
Parent Element
WienerOPCS
Child Elements
none
Element Attributs
Attribute | Default | Description
TraceErrorLevel | 0xffffffff | All error messages enabled
TraceWarningLevel | 0xffffffff | All warning messages enabled
TraceInfoLevel | 0x00000003 | Some informational messages enabled
TraceDebugLevel | 0x00000000 | All debug messages disabled. Enabling debug will produce massive output to the log files ans slow down the system!
TraceFileMaxSize | 1000000 | Maximum trace file size(MB)
TraceFile | OPCSlog.log | Name of trace file
TraceMaxBackups | 1 | The maximum number of backups Trace files created
Remarks:
  • The "Debug" section contains the name of (alterneted) log files, the maximum file size, a global variable which enables/disables complete logging, and separate logging variables for ERROR, WARNING, INFORMATION and DEBUG. Each bit in the variables enables/disables certain debug messages.
    Setting DEBUG to 0xffffffff will produce massive output (which may decrease the performance of the server).
    If no log filename is defined in the configuration, the file "OPCSlog.log" will be used. DEBUG versions of the server send the messages to the system debugger, too, which can be captured with siutable tools (e.g. DebugView)
See also:
Configuration File Element Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:38 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: SNMP

WienerOPCS » Configuration File Reference » WienerOPCS

SNMP

All SNMP-specific parameters.

Element Name

SNMP

Parent Element

WienerOPCS

Child Elements

none

Attributes

Element Attributs
Attribute | Default | Description
ReadCommunity | public | Community name for SNMP get operations.
WriteCommunity | private | Community name for SNMP set operations.
Timeout | 100 | The default time span (in milliseconds) after a message is resent if no response had arrived. The OPC server knows the necessary exact timeout value for many specific data items. The default value is used only if the specific value is unknown.
Retries | 2 | The number of times the message is retransmitted after a timeout.
UserDataPriority | 1.0 | The relation of USER_DATA / MEASUREMENT_DATA i/o operations.
MaximumTransfersPerSecond | 10.0 | The maximum number of i/o-operations per connected device per second. Zero means no limit.

Access Level

The SNMP subsystem uses different community names for different access levels. The higher access level includes the lower ones. The OPC server uses the ReadCommunity string for all read operations, and the WriteCommunity string for all write operations.
The ReadCommunity and WriteCommunity attributes must be set to the appropriate community name of the controlled crates.
Example: If change of the output voltage should be performed by the OPC server, the WriteCommunity string must be set to the level 3 crate community name, default "guru".

Access Level | SNMP Default Community Name | Description
R0 | public | Only read access.
R0, W1 | private | Switching channels on and off allowed.
R0, W2 | admin | Change of supervision limits allowed.
R0, W3 | guru | Change of output voltage and current limit allowed.

See also:
Configuration File Element Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:34 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: CAN

WienerOPCS » Configuration File Reference » WienerOPCS

CAN

All CAN-bus specific parameters.

This configuration element contains one child element (starting with Interface0) for each logical CAN-bus interface of the computer.
There must be at least one interface element.

Element Name

CAN

Parent Element

WienerOPCS

Child Elements

  • Interface0
  • Interface1
  • ...
  • Interface15

Element Relation

Attributes

none
See also:
Configuration File Element Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:34 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Interface0, Interface1, ..., Interface15

WienerOPCS » Configuration File Reference » WienerOPCS » CAN

Interface0, Interface1, ..., Interface15

Data of one logical CAN-bus interface.

Element Name

Interface..

Parent Element

CAN

Child Elements

none

Attributes

Element Attributs
Attribute | Default | Description
Driver | Kvaser | Defines the type of the used driver. Allowed values are Kvaser, Peak.
Channel | the lowest available | The physical CAN-bus channel number of the driver (output connector number), starting at 0.
BitRate | 1M | Transfer speed of this channel. Allowed values are 1M, 500k, 250k, 125k, 100k, 50k, 20k, 10k, 5k
Timeout | 500 | The default time span (in milliseconds) after a message is resent if no response had arrived. The OPC server knows the necessary exact timeout value for many specific data items. The default value is used only if the specific value is unknown.
Retries | 1 | The number of times the message is retransmitted after a timeout.
UserDataPriority | 1.0 | The relation of USER_DATA / MEASUREMENT_DATA i/o operations.
MaximumTransfersPerSecond | 10.0 | The maximum number of i/o-operations per connected device per second. Zero means no limit.
See also:
Configuration File Element Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:34 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Crates

WienerOPCS » Configuration File Reference » WienerOPCS

Crates

Collection of all crates controlled by this server.

Element Name

Crates

Parent Element

WienerOPCS

Child Elements

  • Crate

Element Attributs
none
See also:
Configuration File Element Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:35 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Crate

WienerOPCS » Configuration File Reference » WienerOPCS » Crates

Crate

Data of one specific crate.

There is one crate element for each existing crate.

Element Name

Crate

Parent Element

Crates

Child Elements

none

Attributes

Attribute | Default | Description
Alias no default OPC node name for this crate. If the Address attribute is a range, the enumerated part of the address can be inserted at any position with the standard printf() format.
Example: Alias="CAN Crate %2.2d" and Address="0.1-3" will create three crates with the aliasses "CAN Crate 01", "CAN Crate 02" and "CAN Crate 03".
Transport | SNMP | Network transport. Allowed values are SNMP, CAN
Address SNMP:
127.0.0.1
or CAN:
0.1
Address string.
TCPIP: Dotted-decimal IP address of the crate.
An address range can be defined with the format XXX.YYY.ZZZ.START-END, where XXX, YYY and ZZZ are fixed values and START and END define the enumeration range.
CAN: The address (1..127) of the crate. If more than one CAN-bus interface is available, the logical interface number (starting with 0) seperated by a dot is preceded. (see CAN) An address range can be defined with the format IF.START-END, where IF is the fixed interface number and START and END define the enumeration range.

Remarks:
Depending on the transport type specific prerequisites must be satisfied:
  • NetSNMP and TCPIP connection for SNMP.
  • KVASER driver for CAN.
See also:
Configuration File Element Index
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:35 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: WienerOPCS Command Line Parameters

WienerOPCS

WienerOPCS Command Line Parameters

Usage: WienerOPCS [option]

Options:

  • -r, -RegServer
    Registers the server in the Windows registry.
    This is necessary to start the server automatically by the OpcEnum service.
    This is done during the WienerOPCS installation.
  • -u, -UnRegServer
    Unregisters the server in the Windows registry.
  • -e, -Embedded
    Embedded operation: Terminates server if not used.
  • -c ConfigFile
    Specifies the configuration file (default: WienerOPCS.cfg).
  • Any illegal option will show a short help message and terminate the program.
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:38 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Modifying the WienerOPCS Service behavior

WienerOPCS

Modifying the WienerOPCS Service behavior

Registering the OPC server sets all necessary Windows registry items.

The default behavior is to start the server with the -embedded option, which automatically terminates the server after the last client disconnects. This can be changed by editing the Windows registry. If you are not familiar with the Windows registry and its tools contact your system administrator. Doing something wrong can destroy your complete system!

The relevant key is stored under \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WienerOPCS\ImagePath. If you have installed the server at the default location, its value is

"C:\Program Files\W-IE-NE-R\WienerOPCS\WienerOPCS.exe -embedded"

If you do not want the server to terminate automatically remove the " -embedded" string from the value.

The OPC server must be restarted to recognize the changes.

W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:38 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: OPC Namespace Index

WienerOPCS

OPC Namespace Index

This is an alphabetically sorted list of all WienerOPCS namespace nodes.
  • Channel
  • Channel Number
  • crate name
  • Output
  • Group
  • Group Number
  • root of the namespace
  • Server
  • Status (Output.Status)
  • Status (System.Status)
  • SupervisionBehavior
  • System
  • TestObjects
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:37 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Configuration File Element Index

WienerOPCS

Configuration File Element Index

This is an alphabetically sorted list of all WienerOPCS.cfg configuration elements.

  • CAN
  • Crate
  • Crates
  • Debug
  • Interface (CAN-bus configuration)
  • SNMP
  • WienerOPCS
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:38 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Software License

WienerOPCS

Software License

License Agreement

Wiener-OPCS

Copyright © 2005-2012 W-IE-NE-R Plein & Baus GmbH, Muellersbaum 20, 51399 Burscheid, Germany.

President/Geschäftsführer : Manfred Plein

Lower district court / Amtsgericht: Köln HRB 48878

VAT-ID/Ust.-Id.-Nr.: DE 123 715 792

All rights reserved. Please contact the company for detailes of the license contract.

Unless required by applicable law or agreed to in writing, the software is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. Parts of the software use functions of the Net-SNMP project (www.net-snmp.org) and the xerces project (www.apache.org). These licenses are included below.

Net-SNMP

Various copyrights apply to this package, listed in various separate parts below. Please make sure that you read all the parts. Up until 2001, the project was based at UC Davis, and the first part covers all code

written during this time. From 2001 onwards, the project has been based at SourceForge, and Networks Associates Technology, Inc hold the copyright on behalf of the wider Net-SNMP community, covering all derivative work done since then. An additional copyright section has been added as Part 3 below also under a BSD license for the work contributed by Cambridge Broadband Ltd. to the project since 2001.

An additional copyright section has been added as Part 4 below also under a BSD license for the work contributed by Sun Microsystems, Inc. to the project since 2003.

Code has been contributed to this project by many people over the years it has been in development, and a full list of contributors can be found in the README file under the THANKS section.

---- Part 1: CMU/UCD copyright notice: (BSD like) -----

Copyright 1989, 1991, 1992 by Carnegie Mellon University

Derivative Work - 1996, 1998-2000

Copyright 1996, 1998-2000 The Regents of the University of California

All Rights Reserved

Permission to use, copy, modify and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appears in all copies and that both that copyright notice and this permission notice appear in supporting documentation, and that the name of CMU and The Regents of the University of California not be used in advertising or publicity pertaining to distribution of the software without specific written permission.

CMU AND THE REGENTS OF THE UNIVERSITY OF CALIFORNIA DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL CMU OR THE REGENTS OF THE UNIVERSITY OF CALIFORNIA BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM THE LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

---- Part 2: Networks Associates Technology, Inc copyright notice (BSD) -----

Copyright (c) 2001-2003, Networks Associates Technology, Inc

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

· Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

· Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

· Neither the name of the Networks Associates Technology, Inc nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 3: Cambridge Broadband Ltd. copyright notice (BSD) -----

Portions of this code are copyright (c) 2001-2003, Cambridge Broadband Ltd.

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

· Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

· Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

· The name of Cambridge Broadband Ltd. may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR

BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 4: Sun Microsystems, Inc. copyright notice (BSD) -----

Copyright © 2003 Sun Microsystems, Inc., 4150 Network Circle, Santa Clara, California 95054, U.S.A. All rights reserved.

Use is subject to license terms below.

This distribution may include materials developed by third parties.

Sun, Sun Microsystems, the Sun logo and Solaris are trademarks or registered trademarks of Sun Microsystems, Inc. in the U.S. and other countries.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

· Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

· Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

· Neither the name of the Sun Microsystems, Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 5: Sparta, Inc copyright notice (BSD) -----

Copyright (c) 2003-2004, Sparta, Inc

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

· Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

· Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

· Neither the name of Sparta, Inc nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 6: Cisco/BUPTNIC copyright notice (BSD) -----

Copyright (c) 2004, Cisco, Inc and Information Network Center of Beijing University of Posts and Telecommunications.

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

· Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

· Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

· Neither the name of Cisco, Inc, Beijing University of Posts and Telecommunications, nor the names of their contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Apache

Apache License

Version 2.0, January 2004

http://www.apache.org/licenses/

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

1. Definitions.

"License" shall mean the terms and conditions for use, reproduction, and distribution as defined by Sections 1 through 9 of this document.

"Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is granting the License.

"Legal Entity" shall mean the union of the acting entity and all other entities that control, are controlled by, or are under common control with that entity. For the purposes of this definition, "control" means (i) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the outstanding shares, or (iii) beneficial ownership of such entity.

"You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by this License.

"Source" form shall mean the preferred form for making modifications, including but not limited to software source code, documentation source, and configuration files.

"Object" form shall mean any form resulting from mechanical transformation or translation of a Source form, including but not limited to compiled object code, generated documentation, and conversions to other media types.

"Work" shall mean the work of authorship, whether in Source or Object form, made available under the License, as indicated by a copyright notice that is included in or attached to the work (an example is provided in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or derived from) the Work and for which the editorial revisions, annotations, elaborations, or other modifications represent, as a whole, an original work of authorship. For the purposes of this License, Derivative Works shall not include works that remain separable from, or merely link (or bind by name) to the interfaces of, the Work and Derivative Works thereof.

"Contribution" shall mean any work of authorship, including the original version of the Work and any modifications or additions to that Work or Derivative Works thereof, that is intentionally submitted to Licensor for inclusion in the Work by the copyright owner or by an individual or Legal Entity authorized to submit on behalf of the copyright owner. For the purposes of this definition, "submitted" means any form of electronic, verbal, or written communication sent to the Licensor or its representatives, including but not limited to communication on electronic mailing lists, source code control systems, and issue tracking systems that are managed by, or on behalf of, the Licensor for the purpose of discussing and improving the Work, but excluding communication that is conspicuously marked or otherwise designated in writing by the copyright owner as "Not a Contribution."

"Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom a Contribution has been received by Licensor and subsequently incorporated within the Work.

2. Grant of Copyright License.

Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare Derivative Works of, publicly display, publicly perform, sublicense, and distribute the Work and such Derivative Works in Source or Object form.

3. Grant of Patent License.

Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable (except as stated in this section) patent license to make, have made, use, offer to sell, sell, import, and otherwise transfer the Work, where such license applies only to those patent claims licensable by such Contributor that are necessarily infringed by their Contribution(s) alone or by combination of their Contribution(s) with the Work to which such Contribution(s) was submitted. If You institute patent litigation against any entity (including a cross-claim or counterclaim in a lawsuit) alleging that the Work or a Contribution incorporated within the Work constitutes direct or contributory patent infringement, then any patent licenses granted to You under this License for that Work shall terminate as of the date such litigation is filed.

4. Redistribution.

You may reproduce and distribute copies of the Work or Derivative Works thereof in any medium, with or without modifications, and in Source or Object form, provided that You meet the following conditions:

(a) You must give any other recipients of the Work or Derivative Works a copy of this License; and

(b) You must cause any modified files to carry prominent notices stating that You changed the files; and

(c) You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent, trademark, and attribution notices from the Source form of the Work, excluding those notices that do not pertain to any part of the Derivative Works; and

(d) If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that You distribute must include a readable copy of the attribution notices contained within such NOTICE file, excluding those notices that do not pertain to any part of the Derivative Works, in at least one of the following places: within a NOTICE text file distributed as part of the Derivative Works; within the Source form or documentation, if provided along with the Derivative Works; or, within a display generated by the Derivative Works, if and wherever such third-party notices normally appear. he contents of the NOTICE file are for informational purposes only and do not modify the License. You may add Your own attribution notices within Derivative Works that You distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such additional attribution notices cannot be construed

as modifying the License.

You may add Your own copyright statement to Your modifications and may provide additional or different license terms and conditions for use, reproduction, or distribution of Your modifications, or for any such Derivative Works as a whole, provided Your use,reproduction, and distribution of the Work otherwise complies with the conditions stated in this License.

5. Submission of Contributions.

Unless You explicitly state otherwise, any Contribution intentionally submitted for inclusion in the Work by You to the Licensor shall be under the terms and conditions of this License, without any additional terms or conditions.

Notwithstanding the above, nothing herein shall supersede or modify the terms of any separate license agreement you may have executed with Licensor regarding such Contributions.

6. Trademarks.

This License does not grant permission to use the trade names, trademarks, service marks, or product names of the Licensor, except as required for reasonable and customary use in describing the origin of the Work and reproducing the content of the NOTICE file.

7. Disclaimer of Warranty.

Unless required by applicable law or agreed to in writing, Licensor provides the Work (and each Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, including, without limitation, any warranties or conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A PARTICULAR PURPOSE. You are solely responsible for determining the appropriateness of using or redistributing the Work and assume any risks associated with Your exercise of permissions under this License.

8. Limitation of Liability.

In no event and under no legal theory, whether in tort (including negligence), contract, or otherwise, unless required by applicable law (such as deliberate and grossly negligent acts) or agreed to in writing, shall any Contributor be liable to You for damages, including any direct, indirect, special, incidental, or consequential damages of any character arising as a result of this License or out of the use or inability to use the Work (including but not limited to damages for loss of goodwill, work stoppage, computer failure or malfunction, or any and all other commercial damages or losses), even if such Contributor has been advised of the possibility of such damages.

9. Accepting Warranty or Additional Liability.

While redistributing the Work or Derivative Works thereof, You may choose to offer, and charge a fee for, acceptance of support, warranty, indemnity, or other liability obligations and/or rights consistent with this License. However, in accepting such obligations, You may act only on Your own behalf and on Your sole responsibility, not on behalf of any other Contributor, and only if You agree to indemnify, defend, and hold each Contributor harmless for any liability incurred by, or claims asserted against, such Contributor by reason of your accepting any such warranty or additional liability.

W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:37 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: Page Index

WienerOPCS Related Pages

Here is a list of all related documentation pages:
  • CANbus Messages from WIENER UEP6 Power Supplies.
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:38 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5


WienerOPCS: CANbus Messages from WIENER UEP6 Power Supplies.

CANbus Messages from WIENER UEP6 Power Supplies.

The following messages are possible:
  • RTR Request
    May be sent at any time.

An answer (data) will be received. If there are multiple read requests for the same identifier, the crate will answer only once. 7 identifiers per crate.

  • Write Message (no answer expected)
    There is just one buffer at the crate side. An error message will be returned if this buffer is not free. 1 identifier per crate.
  • Read Indexed Data
    A message is sent to a specific crate. An answer (data) will be received. If there are multiple read requests for the same index, the crate will answer only once. 2 identifiers per crate, 128 indices each.
  • Write Indexed Data
    A message is sent to a specific crate. An answer (status) will be received. The next message may not be sent before the answer has been received, else the data may be lost. 2 identifiers per crate, 128 indices each.
  • Data without Request
    This data will be generated by the crate in case of critical situations (e.g. power failure). 1 identifier per crate.
W-IE-NE-R Plein & Baus GmbH Generated on Thu Jul 12 11:39:38 2012 for WienerOPCS 4.0.1912.0 by doxygen 1.4.5